n° 219
Novembre 2017
Luglio 16, 2018, 11:02:42 *
Benvenuto! Accedi o registrati.
Hai dimenticato l'e-mail di attivazione?

Accesso con nome utente, password e durata della sessione
Notizia:
 
   Indice   Linux Windows Techassistance Gameassistance videogame hardware Aiuto Ricerca Agenda Downloads Accedi Registrati  


* Messaggi recenti
Messaggi recenti
Pagine: [1]   Vai giù
  Stampa  
Autore Discussione: modalità debug su wordpress dockerizzato  (Letto 1746 volte)
0 utenti e 1 Utente non registrato stanno visualizzando questa discussione.
sharax
Newbie
*

Karma: +0/-0
Scollegato Scollegato

Messaggi: 8


Mostra profilo
« inserita:: Marzo 20, 2018, 07:44:38 »

Codice:
$ cat docker-compose.yml version: '3.3'
services:
   db:
     image: mysql:5.7
     volumes:
       - dbdata:/var/lib/mysql
     restart: always
     environment:
       MYSQL_ROOT_PASSWORD: somewordpress
       MYSQL_DATABASE: wordpress
       MYSQL_USER: wordpress
       MYSQL_PASSWORD: wordpress
   wordpress:
     depends_on:
       - db
     image: wordpress:latest
     ports:
       -"8000:80"
     restart: always
     environment:
       WORDPRESS_DB_HOST: db:3306
       WORDPRESS_DB_USER: wordpress
       WORDPRESS_DB_PASSWORD: wordpress
       WP_DEBUUG: 'true'
volumes:
    dbdata:

$ docker-compose up -d

$ firefox http://localhost:8000

Tutto sembra funzionare ma, facendo delle verifiche, la modalità debug non sembra sia stata attivata, nonostante abbia specificato nel file docker-compose.yml

WP_DEBUUG: 'true'

Perhè?
Registrato
michele.p
Administrator
Sr. Member
*****

Karma: +11/-2
Scollegato Scollegato

Messaggi: 659


Mostra profilo
« Risposta #1 inserita:: Marzo 20, 2018, 09:53:51 »

La funzione - vado a memoria - dovrebbe chiamarsi wp_debug (con una sola "u").  Occhi al cielo
Registrato
sharax
Newbie
*

Karma: +0/-0
Scollegato Scollegato

Messaggi: 8


Mostra profilo
« Risposta #2 inserita:: Marzo 21, 2018, 10:12:19 »

La funzione - vado a memoria - dovrebbe chiamarsi wp_debug (con una sola "u").  Occhi al cielo

Che?Che?!?
 Che?!? Che?!? Che?!?
La funzione...Che?!?
Registrato
michele.p
Administrator
Sr. Member
*****

Karma: +11/-2
Scollegato Scollegato

Messaggi: 659


Mostra profilo
« Risposta #3 inserita:: Marzo 21, 2018, 11:48:21 »

Uffa....  Ghigno vado per associazione di idee...

la sintassi corretta è:

wp_debug:

e non con la doppia "U". UN esempio puoi vederlo qui:

https://github.com/vccw-team/vccw/blob/master/provision/default.yml
Registrato
sharax
Newbie
*

Karma: +0/-0
Scollegato Scollegato

Messaggi: 8


Mostra profilo
« Risposta #4 inserita:: Marzo 21, 2018, 12:42:23 »

Uffa....  Ghigno vado per associazione di idee...

la sintassi corretta è:

wp_debug:

e non con la doppia "U". UN esempio puoi vederlo qui:

https://github.com/vccw-team/vccw/blob/master/provision/default.yml

Codice:
$ cat docker-compose.yml
version: '3.3'

services:
   db:
     image: mysql:5.7
     volumes:
       - dbdata:/var/lib/mysql
     restart: always
     environment:
       MYSQL_ROOT_PASSWORD: somewordpress
       MYSQL_DATABASE: wordpress
       MYSQL_USER: wordpress
       MYSQL_PASSWORD: wordpress

   wordpress:
     depends_on:
       - db
     image: wordpress:latest
     ports:
       - "8000:80"
     restart: always
     environment:
       WORDPRESS_DB_HOST: db:3306
       WORDPRESS_DB_USER: wordpress
       WORDPRESS_DB_PASSWORD: wordpress
       WP_DEBUG: true
volumes:
    dbdata:

$ docker-compose up -d --build
ERROR: The Compose file './docker-compose.yml' is invalid because:
services.wordpress.environment.WP_DEBUG contains true, which is an invalid type, it should be a string, number, or a null
Registrato
morpheusWM
Jr. Member
**

Karma: +1/-10
Scollegato Scollegato

Messaggi: 53


Mostra profilo
« Risposta #5 inserita:: Marzo 22, 2018, 11:18:03 »

Prova mettendo true tra apici: 'true'
Registrato
sharax
Newbie
*

Karma: +0/-0
Scollegato Scollegato

Messaggi: 8


Mostra profilo
« Risposta #6 inserita:: Marzo 22, 2018, 04:12:27 »

Prova mettendo true tra apici: 'true'

Già provato.
In un file di un mio plugin di test ho messo

var_dump(WP_DEBUG)

ma mi da FALSE

Cmq tu non riesci a fare qualche prova?
Ti crei il file  docker-compo.yml come il mio e lo fai partire.

Non facciamo prima?
Registrato
Max.Riservo
Global Moderator
Sr. Member
*****

Karma: +24/-0
Scollegato Scollegato

Messaggi: 854



Mostra profilo
« Risposta #7 inserita:: Marzo 22, 2018, 07:06:44 »

Leggere questo link e verificare anche il file wp-config.php
Registrato

I Moderatori invitano tutti gli Utilizzatori del forum a prendere visione del REGOLAMENTO e a rispettarlo.
sharax
Newbie
*

Karma: +0/-0
Scollegato Scollegato

Messaggi: 8


Mostra profilo
« Risposta #8 inserita:: Marzo 22, 2018, 10:49:50 »

Leggere questo link e verificare anche il file wp-config.php

e come faccio a modificare wp-config.php nel container?
Registrato
Pagine: [1]   Vai su
  Stampa  
 
Vai a:  

Copyright © 2017 Edizioni Master SpA. p.iva : 02105820787

Tutti i diritti di proprietà letteraria e artistica riservati. - Privacy



powered by Simple Machines